Page 1 of 1

Web site security - display of images

Unread postPosted: Fri Feb 24, 2017 5:54 pm
by John Hinson
With the current trends on security, I have enabled "SSL" on the main part of The Signalbox web site.

You don't need to worry about what it is and how it works, but web addresses use https:// for the prefix rather than http:// . If you visit the main site using the old address it will simply divert you to the new one so there is no need for any special action there.

However, images I have stored there for display on this site will not load unless I adjust the code. Please tell me by PM if you come across any and I can correct them - it is quite a task as each has to be edited manually but if I do them as and when it shouldn't be a problem.

In due course I will be activating SSL on the forum, too, and I will let you know once it is active. Again it should need no special action on your part.

However, your browser may warn of insecurity (mixed secure and non-secure content) when loading an image from a site that doesn't have SSL. This is really nothing to worry about, it will still be more secure than the present arrangements (which aren't exactly insecure!).

John

Re: Web site security - display of images

Unread postPosted: Fri Feb 24, 2017 8:07 pm
by Chris Osment
You don't need to worry about what it is and how it works, but web addresses use https:// for the prefix rather than http:// . If you visit the main site using the old address it will simply divert you to the new one so there is no need for any special action there.


Ah - that explains why my bookmark to 'Exchange Sidings' suddenly started taking me to the Home page instead!

Re: Web site security - display of images

Unread postPosted: Sat Feb 25, 2017 1:05 am
by John Hinson
Chris Osment wrote:Ah - that explains why my bookmark to 'Exchange Sidings' suddenly started taking me to the Home page instead!

Now that surprises me. It should simply jump you to the new https:// prefix. I guess bookmarks must work differently to typing in a URL or following a link from another page.

John

Re: Web site security - display of images

Unread postPosted: Sat Feb 25, 2017 3:21 pm
by Danny252
Similarly, the change has also broken images included in posts, e.g. John's first post this thread: viewtopic.php?p=79213#p79213

Attempting to view the image directly results in redirection.

Edit: This seems to have broken any direct link to the site, for some reason; e.g. www.signalbox.org/gallery/lm/crowthornjcn.php redirects to the home page, unless I manually add "https://" myself.

Re: Web site security - display of images

Unread postPosted: Sat Feb 25, 2017 3:47 pm
by John Hinson
Danny252 wrote:This seems to have broken any direct link to the site, for some reason; e.g. http://www.signalbox.org/gallery/lm/crowthornjcn.php redirects to the home page, unless I manually add "https://" myself.

This should not happen, it may be a quirk of the forum software causing that. As with images please let me know by PM of the URL of any you come across on the forum here and I will fix them.

Thanks,

John